I saw that problem a few weeks ago on a youtube thumbnail, it’s quite a nice problem and I think it gets even more interesting if you start to consider 5^3 or even 5^N horses. Cool that you actually coded a solution for it! I like the idea of hiding the actual values to prevent the developer from cheating :)
I haven’t really checked whether you program does exactly what I’d expect it to do since I had a hard time to understand what’s happening.
I think a few comments here and there would help to understand what exactly is going on and maybe some better names would hep, too (example: number_matrix
- what does it do? I see from the type that it is a 2d array of ints but what does it contain and how does it relate to horse_matrix
).
I still have some general recommendations for you how you could improve your code:
- You seem to use OS specific random numbers, there is a C++ api for that nowadays (
std::random_device
/std::mt19937
) - You call
rand() % 26
and check against 0, in that case you reroll - you could instead directly calculaterand() % 25 + 1
- As alternative to that manual
rand()
approach, you could look intostd::shuffle
- Take a look at sets (e.g.
std::unordered_set
), they have acontaints()
function that tells you whether a value is in the set or not. It’s not a big issue here but using vectors withstd::count
when all you want to do is check whether an element is in a set will not scale well - Consider using an enum instead of the
char option
. I’d go with something likeenum class Option { kRow, kColumn };
. If you want to stay with a char, I’d recommend not using a preprocessor directive for this () but instead go with a regular constant (e.g.
constexpr char kRow = 'r'
) - Consider using
std::unique_ptr<MatrixPosition>
instead of returning a raw pointer - that way you avoid memory leaks. ignore_count
andignore_vector
are only used in one function, so they don’t have to be members of the class.InitializeMatrix
probably does not need to be a class in the first place.- Consider not using
using namespace std
. For small projects that’s not an issue for bigger ones you’ll find your namespace polluted.
Something that you might also not be aware of is that std::endl
automatically flushes buffers and makes sure that your line is printed immediately. If you don’t need this you can just use \n
instead which is a little bit faster. But that’s more of a “fun fact” than a general recommendation.
Hope that helps and doesn’t sound too harsh, I know how code reviews can feel sometimes…
My personal preference is to leave comments where it’s not directly clear what the code does. Using “good” variable & function names can make the code usually somewhat self-documenting, but that’s not always enough.
Yeah I understood why you used that approach, and I’m not a c++ expert myself, just wanted to point out some other options.
It makes no difference visibility-wise if you have a variable that is local to a function vs a private member of a class that’s just used by said function.
Huh, that sounds odd. Never done anything with LeetCode, but would be interested into seeing what was going on there. If you want to use sets, check whether you need ordering (most likely you don’t) and go with
std::unordered_map
.Absolutely not. I see lots of value of optimizing and cleaning up code, there is so much to learn which will help you write better code in the future. I have a bunch of programming projects that I never fully finished and you could also call them a waste of time - who would play with my gameboy emulator without gui etc? No one besides me :) But it was more about the journey and learning things. So go for it and code things you find interesting, that’s a good way to stay motivated.
Good luck with admissions. Putting effort into it in your spare time and as a hobby is great and shows dedication, exposing your code to “the internet” and asking others for feedback is also a great way to grow - way to go!